A recap on the car issues.. (sans the re-use ramble)

That last car post ended up rambly and encompassed a bunch of topics I’ve been thinking about lately. I think it is worthwhile to get back to the car issues for the sake of anyone else who may encounter the same problems and is googling for a solution.

First, we’re talking about a 1998 ford escort ZX2, however the issues experienced could be common to any Zetec escort 98-2004 as well as other cars with the Zetec engine, like the Mazda MX3 etc.

So first was the shifter problem. The car just stopped going into gear. It appeared that water got into the shifter ball joint and gummed up the grease, eventually wearing big holes in the shifter ball bushings. These bushings, two little rings of plastic, are unavailable on their own. The dealership’s solution was to replace the whole shifter assembly for $500 something, but that seemed kind of dumb. I checked several auto salvage yards, but no cars with this shifter were available. Also notable, a lot of the yards said that they don’t even keep manual transmission vehicles around… weird.

I eventually found that the bushings came with aftermarket short throw shifters, which can be had on ebay for as little as $25 shipped. The setup in these was a little different than OEM though. In the OEM assembly, below the shift ball on the shift lever there was a rubber boot with a metal ring at the top, as best as I could figure this part was held in place by a small lip at the bottom of the collet plate. Then the lower bushing went above this, then the shifter ball, the upper bushing and then the spring retainer that held the whole thing together. The aftermarket piece had the shift ball and bushings all contained in an aluminum tube held together with a snap ring. This tube seems to be intended for friction fit in the collet plate, because there is no room for the spring retainer. It seems to be really stable there, so “oh well” I guess.

The other problem here was that the OEM shift lever had little rubber bushings that went around the shoulder bolt that attached to the shift linkage. The originals were pretty trashed, but again, this part appears to just be unavailable. I tried ordering a couple of pieces from energy suspension, but when I finally got the correct one for this vehicle, I found it to be for the transmission end of the shift linkage. In the end, I finally just used the tattered remains of the OEM parts, and it seems to work fine.

Then there was the temp sensor problem. Basically, I found out that these cars have 2 temp sensors. The top one apparently only gets readings for the ECM in regards to engine A/F calculations. The lower one (that’s really difficult to get to) reads for both the temp gauge on the dash and the cooling fan operations.

The hangup here is that autozone and every other parts store I went to only had the top sensor. After taking it to the stealership and getting a quote for $280 something for them to change it out, I went back to autozone with the old sensor and went through other cars with the zetec 2.0. They should have actual photos on their search terminal, so you can check to make sure it’s the right one. I think I ended up getting one from a 98 contour.

Getting to the part on the car was pretty brutal. I ended up removing the upper rad hose, and the coolant hose below the thermostat housing, then removed the thermostat housing. Even then, I could barely make any progress with an open end wrench. A regular socket was not deep enough, and a deep well socket wouldn’t clear the space to get it on the sensor. If I had to do it again, I’d cut a bit off a deep well and see if that would land on it.

Everything is working well now, and to my surprise, the ebay shifter is holding up and shifts as good as the original one. Also, I would like to mention that the Ford Escort owners association site was helpful in gathering info on these problems. At the end of the day, I couldn’t find _all_ the solutions there, but there was a lot of context to the problems that helped.

Advertisements

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s